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Document ConventionDocument ConventionDocument ConventionDocument Convention 
 

� SXDE 1/08SXDE 1/08SXDE 1/08SXDE 1/08 – Solaris Express Developer Edition 1/08 (Solaris OS). 
� Web StackWeb StackWeb StackWeb Stack – The AMP (Apache, MySQL, and PHP) software available through the SXDE 

1/08. 
� AMP GUIAMP GUIAMP GUIAMP GUI – Web Stack Configuration Tool. 
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1111 OOOOverviewverviewverviewverview    
Solaris OS offers complete support for developing and deploying applications for the web. 
Starting from SXDE 1/08, a collection of some of the most commonly used open source 
applications and frameworks are bundled with the OS. These applications comprise the Web 
Stack and include several packages that are optimized for the Solaris OS and aid in web based 
development in Solaris OS. 
SXDE 1/08 also has NetBeans IDE, a free open-source IDE for creating professional desktop, 
enterprise, web, and mobile applications.  
 

 
A Complete Stack Offering from NetBeans 
 

This document shows you how you can use NetBeans IDE to build web application on Solaris 
OS using the Web Stack components bundled with the OS. Before we dive into the details of 
these components, let us enumerate the stages involved in developing an end to end 
enterprise grade web application. 
What do you expect from an IDE if you are planning to use the IDE for web development?  
 

� Server supportServer supportServer supportServer support – Your IDE should support managing the Server lifecycle through an 
intuitive and easy to use interface. 
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� Languages SupportLanguages SupportLanguages SupportLanguages Support – You will expect the IDE to support working with the programming 
language or web application framework your web application will be eventually built 
on. 

� Database sDatabase sDatabase sDatabase supportupportupportupport – What good is an enterprise application without a database? You 
want your IDE to be well integrated with your development, testing and production 
database. 

 
Typically, your development environment should enable you to build web applications with 
minimal effort offering you extensive support for stack level configuration through property 
editors, wizards, and widgets. Server support, languages support, and database support are 
the three prime facets that any IDE can offer for web development. 
NetBeans IDE on Solaris takes care of all these factors with an elegant interface making web 
development just easy. You can build your web applications in PHP or use Rails framework and 
work with DBs like MySQL DB or PostgreSQL DB in NetBeans. 

2222 Available SoftwareAvailable SoftwareAvailable SoftwareAvailable Software    
 
In Solaris OS, for building web applications the following software are provided: 
 

� NetBeans IDE 6.0 (Available in SXDE 1/08) 
� Web Stack (Available in SXDE 1/08) 
� The Java SE Development Kit (JDK) 5.0 or higher (Available in SXDE 1/08) 

 
If you are using Solaris Express Developer Edition 1/08, you do not need to download 
NetBeans IDE or any other software as the Web Stacks components like the AMP stack and 
Ruby/Rails are already integrated with OS. If you are using OpenSolaris OS, refer to the 
OpenSolaris site on getting the Web Stack IPS package. For all other Solaris OS versions, you 
can download the optimized AMP stack from http://cooltools.sunsource.net/coolstack/ 
 
In SXDE 1/08, Go to All Applications > Developer Tools > Web Stack Admin > View Getting 
Started Guide for information on setting up AMP on Solaris OS. 

3333 RuntimeRuntimeRuntimeRuntime Support Support Support Support    
What good is an IDE without integrated server/runtime support for web development? 
NetBeans IDE on Solaris OS supports various Java EE servers and other web servers for 
application deployment. You can have multiple servers configured in NetBeans irrespective of 
the server that will be used in your projects. Thus you can have Apache 2 Web Server 
configured for deploying PHP files, Apache Tomcat container configured for deploying Java 
based web applications or a WEBrick server for deploying Rails applications. 

3.13.13.13.1 Apache2Apache2Apache2Apache2 Web Server Web Server Web Server Web Server    

Solaris Web Stack bundle comes with Apache 2 Web Server. NetBeans IDE lets you add Apache 
web server in the servers list so the applications that you build including PHP based web 
applications can be deployed to the Apache web server. This section shows you how you can 
set up Apache web server in the NetBeans runtime environment. 



 
 

_____________________________________________________________________________ 
Using NetBeans with Web Stack on Solaris OS      Page 6  

 
If Web Stack is configured in Solaris machine, you do not need to download Apache Web 
Server or PHP engine separately.  See the Web Stack Getting Started Guide to find out how you 
should initialize Web Stack and start MySQL Server. 
 

� Click All Applications > Developer Tools > Web Stack Admin > Initialize 
� Click All Applications > Developer Tools > Web Stack Admin > Start Apache2/MySQL 

Servers 

 
Web Stack comes with Apache 2 Web Server fully configured and optimized for PHP 
deployment. 
 

� Go to Services Tab. 
� Expand Web Servers node. 
� Right Click on Web Servers node and click Add Web Server. 

 
 

 
Add a Web Server 

 
Step 1 – Choose Server Type 

� Add a connection name. For example, Apache 2. 
� Select Local Web Server with File Access option so that you can instruct NetBeans to 

use Apache 2 server installed through Web Stack. 

 
Step 2 –Find Configured Hosts 

� Select Manual Configuration. 
� In the Apache Config File Location field enter /etc/apache2/2.2/httpd.conf 

 

OROROROR    
    

� Select Auto ConfigurationSelect Auto ConfigurationSelect Auto ConfigurationSelect Auto Configuration....    
� Click Find ServersClick Find ServersClick Find ServersClick Find Servers....    
� The Server Location fiThe Server Location fiThe Server Location fiThe Server Location fieeeelllld is automatically populatedd is automatically populatedd is automatically populatedd is automatically populated....    
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Step3 – Configure HTTP Server 

� Enter Server Name as localhost 

 
Step4 Configure File Access 

� Enter Document Root as /var/apache2/2.2/htdocs 

 

ImportantImportantImportantImportant    –––– Document Root direc Document Root direc Document Root direc Document Root directory should be writable by you.tory should be writable by you.tory should be writable by you.tory should be writable by you.    
As root user executeAs root user executeAs root user executeAs root user execute > > > >                    chmod a+w /var/apache2/2.2/htdocs    

 
After adding the server, check if Apache Web Server shows up the Web Servers list by clicking 
Services tab. 
 

 

Apache Web Server Configured 

 
These are the basic steps to get you started with using Apache web server for deploying your 
PHP based web applications. Since Apache Web Server is already configured to support PHP 
files, you do not need to perform any other configuration apart from getting and installing the 
PHP plug-in as shown in the section on PHP. 

3.23.23.23.2 TomcatTomcatTomcatTomcat Web Server Web Server Web Server Web Server    

Solaris Web Stack comes with Tomcat 6.0 Servlet container for deploying your JSP based web 
applications. Some of the examples shown later in this document uses Tomcat in NetBeans. 
NetBeans for Solaris may not come bundled with Tomcat server as Tomcat is already available 
in Solaris through Web Stack. But still you need to let NetBeans know where your Tomcat 
installation directory is to allow NetBeans manage Tomcat’s lifecycle. 
 

� Go to Tools > Servers. 
� In the left pane, click Add Server. 
� Choose Tomcat 6.0 from the servers list. 
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Add Server Instance 

 

� In the Catalina Home field, type /opt/apache-tomcat-6.0.14 (Make sure that 
path exists). 

� Add the user name and password for the manager role as provided in tomcat-

users.xml file in the Tomcat configuration directory. 

 
You can also let NetBeans create a new user if the user entered in the user name text field 
does not exist. 
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Add Server Instance 

 
Configure Tomcat properties 

 
When Tomcat is successfully configured in NetBeans, the Servers node shows Tomcat 6.0 
entry.  
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Servers node shows native Tomcat server 

 
You can right click on the Tomcat 6.0 node and select Start to start the server. 

3.33.33.33.3 WEBrick ServerWEBrick ServerWEBrick ServerWEBrick Server    

NetBeans IDE 6.0 comes bundled with WEBrick, the most widely used Ruby web server. 
WEBrick is started automatically on Rails project creation. There is a WEBrick console window 
that shows the output of the web server. No other manual configuration is required for the 
WEBrick server. For using Mongrel or any other server, update your gems by invoking Tools > 
Ruby gems. 

4444 Languages and Applications SupportLanguages and Applications SupportLanguages and Applications SupportLanguages and Applications Support    
There is a widespread misconception that NetBeans is an IDE for Java development. In fact 
NetBeans IDE supports working with non-Java scripting languages like PHP, Ruby, and other 
such scripting languages. If you are using NetBeans IDE 6.0 in Solaris OS, you can work with 
any of these scripting languages supported by Solaris Web Stack.  This document shows you 
how you can use NetBeans IDE with the language interpreters that come with Solaris OS. 
 

NoteNoteNoteNote –––– Visit http://scripting.netbeans.org for more information on scripting support in 
NetBeans IDE 6.0. 

4.14.14.14.1 PHP SupportPHP SupportPHP SupportPHP Support    

PHP is an interpreted, dynamic, web page scripting language. NetBeans IDE 6.0 has support 
for PHP editing and debugging through an add-on component called PHP plug-in. The plug-in 
supports PHP5 and features: 
 

� Formatting, folding, and bracket completion of the PHP code 
� Syntax highlighting 
� Combination of HTML and PHP blocks 
� Code completion 
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� Debugging 
� Command-line mode 
� Automatic detection of configured servers (for Solaris OS) 

 

Supported VersionSupported VersionSupported VersionSupported Version – PHP 5.2.4 

 
When you have downloaded and configured the plug-in, you should be able to create new PHP 
projects. However to run and debug your PHP projects, you will need: 
 

� Apache 2Apache 2Apache 2Apache 2 - Available through Web Stack. You can use a local server or a remote server 
with FTP access. Typically a local web server is utilized for development and 
debugging, while the production environment is located on a remote web server. 

� PHP enginePHP enginePHP enginePHP engine - Available through Web Stack. 
� PHP debuggerPHP debuggerPHP debuggerPHP debugger - Available through Web Stack PHP Extension. The NetBeans 6.0 IDE PHP 

Plug-in allows you to use XDebug, but using a debugger is optional. 

 
For using PHP and Apache2 through Web Stack, you do not need any additional configuration. 
 

NoteNoteNoteNote - PHP language interpreter is integrated into the Apache Web Server. PHP module with 
MySQL and PostgreSQL database support is provided for Apache HTTP (32-bit) prefork MPM. 
See http://httpd.apache.org/docs/2.2/mod/prefork.html 

 
Some PHP modules are packaged with SXDE as extensions. Each of the modules has a 
respective INI file under /etc/php5/5.2.4/conf.d directory. These PHP extensions are 

enabled by default. Custom third-party PHP extensions like APC, Suhosin, IDN, Tcpwrap, 

XDebug, DTrace are not enabled by default. However, you can edit the PHP extension 

specific INI file for any specific configuration changes.  
For enabling debugging support in PHP, perform the following steps: 
 

� Click All Applications > Developer Tools > Web Stack Admin > Options. 
� Go to PHP tab and click ‘PHP Debugger’ check box. 

 
In the PHP tab, click Advanced Configuration to open the INI file for editing. 
 

ImportantImportantImportantImportant    ---- NetBeans IDE configured for PHP development is  NetBeans IDE configured for PHP development is  NetBeans IDE configured for PHP development is  NetBeans IDE configured for PHP development is already already already already installed in SXDE 1/08. installed in SXDE 1/08. installed in SXDE 1/08. installed in SXDE 1/08. 
The IDE provides support for PHP editing, debugging, and deployment to tThe IDE provides support for PHP editing, debugging, and deployment to tThe IDE provides support for PHP editing, debugging, and deployment to tThe IDE provides support for PHP editing, debugging, and deployment to the Web Stack he Web Stack he Web Stack he Web Stack 
Apache runtime. Apache runtime. Apache runtime. Apache runtime. To invoke the NetBeans PHP IDE, click All Applications > Developer Tools > To invoke the NetBeans PHP IDE, click All Applications > Developer Tools > To invoke the NetBeans PHP IDE, click All Applications > Developer Tools > To invoke the NetBeans PHP IDE, click All Applications > Developer Tools > 
NetBeans PHP IDE 6.0. PHP plugNetBeans PHP IDE 6.0. PHP plugNetBeans PHP IDE 6.0. PHP plugNetBeans PHP IDE 6.0. PHP plug----in is already bundled with this version of NetBeans IDE.in is already bundled with this version of NetBeans IDE.in is already bundled with this version of NetBeans IDE.in is already bundled with this version of NetBeans IDE.    
 

NetBeans PHP IDE is a pre-configured NetBeans setup that only exposes the PHP support. You 
do not need to download any additional PHP modules. This simple PHP configuration also 
allows you to add MySQL or PostgreSQL databases since the drivers are already registered in 
the IDE. NetBeans PHP IDE startup time is lesser than the normal NetBeans IDE. 

4.1.14.1.14.1.14.1.1 Bundled PHP ExtensionsBundled PHP ExtensionsBundled PHP ExtensionsBundled PHP Extensions    
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PHP modules are available in SXDE 1/08 as extensions. Each of the modules has a respective 
INI file under /etc/php5/5.2.4/conf.d directory. These PHP extensions are enabled by 

default. Custom third-party PHP extensions like APC, Suhosin, IDN, Tcpwrap, XDebug, 

and DTrace are not enabled by default. However, you can edit the PHP extension specific INI 

file for any specific configuration changes. Following is the list of PHP extensions available on 
the Solaris OS: 
 

� bcmath  
� exif  
� mbstring  
� pdo_sqlite 
� sysvsem  
� xmlrpc 
� bz2  
� ftp  
� mysql  
� pgsql  
� sysvshm  
� xmlwriter 
� calendar  
� gd  
� mysqli  
� posix  
� tcpwrap  
� xsl 
� ctype  
� gettext  
� openssl  
� shmop  
� tcpwrap  
� zip 
� curl  
� hash  
� pcntl  
� soap  
� tidy  
� zlib 
� dba  
� iconv  
� pdo  
� sockets  
� tokenizer 
� dbase  
� n.so  
� pdo_mysql  
� sqlite  
� wddx 
� dom  
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� ldap  
� pdo_pgsql  
� sysvmsg  
� xmlreader 

 

More InformationMore InformationMore InformationMore Information    
 - Solaris Web Stack Getting Started Guide. Click All Applications > Developer Tools > Web Stack 
Admin > View Getting Started Guide to view the guide. 

4.1.24.1.24.1.24.1.2 Setting Up PHP PlugSetting Up PHP PlugSetting Up PHP PlugSetting Up PHP Plug----in in NetBeansin in NetBeansin in NetBeansin in NetBeans    

PHP editing is supported from NetBeans IDE 6.0. PHP Plug-in is an extension to the NetBeans 
IDE that supports Web development based on PHP. It is one of the series of plugins for 
scripting languages that are supported by the NetBeans IDE. The following sections show you 
how you can get started with NetBeans PHP plug-in. 

4.1.2.14.1.2.14.1.2.14.1.2.1 Download PHP PlugDownload PHP PlugDownload PHP PlugDownload PHP Plug----inininin    

PHP plug-in is not loaded by default in NetBeans 6.0 as the plug-in is still evolving. You need to 
manually download the plug-in and extend NetBeans IDE to support working with PHP files. 
However you can use the NetBeans 6.0 PHP IDE option from the menu. While installing the 
plug-in you can set up a web server environment for deploying your PHP projects. NetBeans 
comes bundled with Apache Tomcat Servlet Container and not Apache Web Server. You need 
to follow the steps mentioned in the rest of the sections to successfully configure Apache Web 
Server in NetBeans IDE. 
 

� Click Tools > Plugins. 
� Click Available Plugins Tab. 
� Click Reload Catalog to update the list of plugins from different sources. 
� Scroll down the list till you find the PHP plug-in under Scripting Category. 
� Select the plug-in and click Install. The plug-in will be downloaded from one f the 

NetBeans repository. 
� Restart the IDE for the plug-in to be functional. 
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Download PHP Plug-in. 

 

You do not need to download PHP plug-in for NetBeans, if you are using the NetBeans PHP IDE 
6.0 is SXDE 1/08. Click All Applications > Developer Tools > NetBeans 6.0 PHP IDE. 

4.1.34.1.34.1.34.1.3 Create a PHP ProjectCreate a PHP ProjectCreate a PHP ProjectCreate a PHP Project    

When you install the PHP plug-in, a new project type is created. You can either create a new 
PHP project or create a PHP project with existing sources.  
 

� Click File > New Project. 
� Select PHP Project from PHP Categories. 
� Enter project name as MyApp and Click Next. 

� Select Apache2 as the configured Web Server. 
� Enter Context Path as /MyAPP. 

� Enter HTTP Path as http://localhost/MyApp. 

� Enter Document Path as /var/apache2/2.2/htdocs/MyApp. 

 
While creating the project, you have the option of creating an index file. Note that MyApp 
Source Files contain index.php. Modify the code to print “Hello NetBeans”. 
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Print Hello 

4.1.44.1.44.1.44.1.4 Test Your PHP ProjectTest Your PHP ProjectTest Your PHP ProjectTest Your PHP Project    

Start Apache Web Server by running httpd or using Solaris SMF. httpd is located in 

/usr/apache2/2.2/bin. 

For running Apache 2 Web Server, as root user execute: 
 

� $ /usr/sbin/svcadm enable apache2 

 
OROROROR    
    

� Click All Applications > Developers Tools > Web Stack Admin > Start Apache2/MySQL 
Servers. 

 
When Apache Web Server is running, right click on index.php and click execute the file. The 

file will be uploaded to the server’s document root and a web browser window will open to 
show the output. 
 

 
PHP Files are uploaded to the Server’s Document Directory 

 

NoteNoteNoteNote - In a PHP file type phpinfo() and run the file to see the Web Stack PHP configuration 

that provides a way to debug your PHP and server environment. 
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4.1.54.1.54.1.54.1.5 PHP Configuration PHP Configuration PHP Configuration PHP Configuration throughthroughthroughthrough AMP GUI AMP GUI AMP GUI AMP GUI    

You can use the AMP Web App Development Option GUI to modify PHP settings as supported 
by Apache Web Server.  For invoking the GUI tool, click Developer Tools > WebStack Admin > 
Options. 
 

 
PHP Configuration through AMP GUI 

 
PHP Debugger is not enabled by default. You need to click PHP Debugger check box to enable 
this option. NetBeans IDE supports the use of XDebug for debugging PHP projects. 
 

More InformationMore InformationMore InformationMore Information    
    ----    http://wiki.netbeans.org/wiki/view/PHPDebugging 
 - http://php.netbeans.org/docs/plugin-quick-start.html 
 - http://php.netbeans.org/docs/system-requirements.html 

 

4.24.24.24.2 Ruby SupportRuby SupportRuby SupportRuby Support    

NetBeans features plug-ins that provides an integrated development environment for building, 
running, testing, and debugging Ruby and Ruby on Rails applications. NetBeans supports Ruby 
project types including Ruby files, RSpec specification files, and YAML files. You can 
configure NetBeans to use the native ruby available through Web Stack. The IDE also supports 
Rake build tool integration and gives you access to the Interactive Ruby Shell. 
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Supported VersionSupported VersionSupported VersionSupported Version – Ruby 1.8 

 

NoteNoteNoteNote – If you need to use the Gem Manager, you must have gem installed, and the IDE must 
have write permission to your Ruby installation directory. 

4.2.14.2.14.2.14.2.1 Where is Ruby?Where is Ruby?Where is Ruby?Where is Ruby?    

You do not need to download and install ruby if you are using Solaris with Web Stack.  
The following list describes the file structure for Ruby: 
/var/ruby/1.8/gem_home contains the Rubygems repository. Configure the 

GEM_HOME environment variable to point to /var/ruby/1.8/gem_home to use this 

installation of Rubygems. 
/usr/ruby/1.8/bin contains the Ruby executable as well as other utility programs, and 

Rubygems programs. These programs are linked from /usr/bin. For example:  

/usr/ruby/1.8/bin/ruby is linked from /usr/bin/ruby1.8, and may be linked 

from /usr/bin/ruby if 1.8 is the latest version of Ruby installed on this system. 

4.2.24.2.24.2.24.2.2 Verifying Your Gem EnvironmentVerifying Your Gem EnvironmentVerifying Your Gem EnvironmentVerifying Your Gem Environment    
$ gem environment 
 RubyGems Environment: 
    - VERSION: 0.9.4 (0.9.4) 
    - INSTALLATION DIRECTORY: /var/ruby/1.8/gem_home 
    - GEM PATH: /var/ruby/1.8/gem_home 
    - REMOTE SOURCES: 
        - http://gems.rubyforge.org 

 

4.2.34.2.34.2.34.2.3 Preparing NetBeans for RubyPreparing NetBeans for RubyPreparing NetBeans for RubyPreparing NetBeans for Ruby    

Before proceeding to use NetBeans for Ruby, you need to set the environmental variable 
GEM_HOME.  
 
For sh -> export GEM_HOME=/var/ruby/1.8/gem_home 
For csh -> setenv GEM_HOME /var/ruby/1.8/gem_home 

 

ImportantImportantImportantImportant - For using gem, make sure you have direct access to internet. If your system is 
behind a firewall or if it uses a proxy server, set the HTTP_PROXY variable. 

 
If you do not set the GEM_HOME environmental variable, NetBeans IDE will not work as the 
available gems cannot be enumerated if you are using a native Ruby environment. So you 
when you click Tools > Ruby Gems, you will get an error as shown in the following figure: 
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Set GEM_HOME before using NetBeans for Rails development. 

For this reason you need to set GEM_HOME for the gem repository to be accessible from the 
NetBeans IDE. 
Also the directory referenced by GEM_HOME should be writeable. So make sure you execute 
the following command as root user: 
 

� $ chmod -R a+w/var/ruby/1.8/gem_home 

4.2.44.2.44.2.44.2.4 Ruby on RailsRuby on RailsRuby on RailsRuby on Rails    

Rails is a full-stack framework for developing database-backed web applications. Rails provide 
a pure-Ruby development environment. RubyGems is the standard Ruby package manager. On 
the Solaris platform, RubyGems are already loaded. Hence you can install Rails and its 
dependencies through the command-line by typing the following command as a root user: 
 

/usr/bin/gem install rails --include-dependencies 

 
You can also install rails directly from NetBeans IDE rather than invoking the gem command 
through command line. The Ruby on Rails environment is set up for the development. You can 
now use NetBeans IDE to create a Ruby on Rails project. When you create a project, the IDE 
creates the same folders and files that a rails command would create. 
 

NoteNoteNoteNote - Depending on the version of SXDE, Rails may not be available automatically. If rails is 
not available, you need to install that using the gem command. 

4.2.4.14.2.4.14.2.4.14.2.4.1 RubRubRubRuby Gemsy Gemsy Gemsy Gems    

Ruby Gems is a system for managing Ruby software libraries. Ruby code packaged in this 
manner is called a gem. Gems allow downloading, installing, and managing your Ruby 
libraries. Web Stack bundle in Solaris does not include a lot of bundled gems as you can use 
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Ruby Gems to download and install additional gems. You can use the NetBeans interface for 
managing Gems. 

4.2.4.24.2.4.24.2.4.24.2.4.2 Downloading GemsDownloading GemsDownloading GemsDownloading Gems    

 
You can manage ruby gems from NetBeans IDE. 
 

� Click Tools > Ruby Gems. 
� Go to New Gems tab. 
� Click Reload Gems. 
� Select the Ruby Gems and click Install. 

 
 

 
Manage Ruby Gems from NetBeans 

 

Important Important Important Important –––– Make sure you install rails 1.x and not 2.x Make sure you install rails 1.x and not 2.x Make sure you install rails 1.x and not 2.x Make sure you install rails 1.x and not 2.x    

4.2.54.2.54.2.54.2.5 NetBeans Ruby SetupNetBeans Ruby SetupNetBeans Ruby SetupNetBeans Ruby Setup    

NetBeans IDE provides extensive support for creating Ruby and Rails applications. You do not 
need to download Ruby as Ruby support is already provided in the NetBeans 6.0 IDE that 
comes with SXDE 1/08. 
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Install Ruby and Rails Plug-in 

Ruby and Rails support has been well documented in NetBeans site. See the links below for 
more information. 
When you download the Ruby and Rails plug-in, you need to restart the IDE for changes to 
take effect.  
For creating a Rails application perform the following steps: 
 

� Click File > New Project 
� Under Ruby category, select Ruby on Rails Application 

 
At this point you will be prompted to select a Ruby interpreter for your project. If you are using 
SXDE 1/08, you can select the optimized native ruby interpreter as shown in the figure below: 
 

 
Choose Native Ruby Interpreter 
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The native ruby interpreter is available at /usr/ruby/1.8/bin/ruby. This path will be 
automatically shown in the Choose Ruby Interpreter dialog. 
 

 
MySQL/PostgreSQL DB support. 

You can select MySQL or PostgreSQL DB for your Rails project. You can also edit the file 
database.yml, which is already configured to use the MySQL adapter as the development 

database by default. You do not need to do any configuration unless the root user requires a 
password. 
The PostgreSQL driver is not pre-installed with NetBeans Ruby support.  You need to install the 
postgres-pr Ruby gem using the Gem Manager as shown in the section on Downloading 
Gems. 
 

Important Important Important Important ----    When using PostgreSQL with JRuby (not native RubyWhen using PostgreSQL with JRuby (not native RubyWhen using PostgreSQL with JRuby (not native RubyWhen using PostgreSQL with JRuby (not native Ruby bundled through Web Stack bundled through Web Stack bundled through Web Stack bundled through Web Stack), ), ), ), 
you need to edityou need to edityou need to edityou need to edit    the the the the database.yml file and uncom file and uncom file and uncom file and uncomment the lines that start with “host”ment the lines that start with “host”ment the lines that start with “host”ment the lines that start with “host”    
and and and and “por“por“por“port” fort” fort” fort” for Ruby access to PostgreSQL  Ruby access to PostgreSQL  Ruby access to PostgreSQL  Ruby access to PostgreSQL to workto workto workto work....    

 
 

More InformationMore InformationMore InformationMore Information    
 - Installing and Configuring Ruby (http://www.netbeans.org/kb/60/ruby/setting-up.html) 
 - Getting started with Ruby and Rails (http://www.netbeans.org/kb/60/ruby/getting-
started.html) 
 - NetBeans IDE Ruby Documentation (http://www.netbeans.org/kb/60/ruby/index.html) – 
Recommended for understanding Ruby and Rails support in NetBeans. 

5555 DB SupportDB SupportDB SupportDB Support    
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NetBeans Database Explorer is a simple database administration tool, which allows the user to 
work with any supported database schema. To invoke the Database Explorer, navigate to the 
Databases node by clicking the Services tab of the Explorer window as shown in the figure. 
 

 
Browse Tables, Views, and Procedures 

 
Within the Databases node is the Drivers node, which contains the JDBC drivers that NetBeans 
supports. To install a new driver, right-click the Drivers node and select New Driver to open the 
New JDBC driver dialog. Fill in the required data (especially the driver class and JAR files) and 
click OK. A node for the new driver will be created under the Drivers node. Right-click this node 
and select the Connect Using command and enter the required connection information 
(database URL, username, password). If everything is correct, the database connection will be 
established. You need to do this only for drivers not bundled in NetBeans. Some of the drivers 
bundled by NetBeans are: 
 

� Java DB – Embedded (org.apache.derby.jdbc.EmbeddedDriver) 
� Java DB – Network (org.apache.derby.jdbc.ClientDriver) 
� JDBC-ODBC Bridge (sun.jdbc.odbc.JdbcOdbcDriver) 
� MySQL (Connector /J Driver) (com.mysql.jdbc.Driver)MySQL (Connector /J Driver) (com.mysql.jdbc.Driver)MySQL (Connector /J Driver) (com.mysql.jdbc.Driver)MySQL (Connector /J Driver) (com.mysql.jdbc.Driver)    
� PosgreSQL (org.postgresql.Driver)PosgreSQL (org.postgresql.Driver)PosgreSQL (org.postgresql.Driver)PosgreSQL (org.postgresql.Driver)    

 
Information about the database schema is presented by the nodes under the connection node. 
You can see the tables with their columns, indexes and foreign keys. You can also see views 
and their columns and stored procedures with their arguments. More information about each 
database element can be found in the Properties window. For instance, data type, size for 
each column are shown. Using the popup menus, it is possible to access commands specific to 
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database elements, such as to create a new table, add a column to an existing table, or view 
data. 
 
NetBeans’ Database Explorer supports the following features: 
 

� Database schema browsingDatabase schema browsingDatabase schema browsingDatabase schema browsing    ----    You can browse database schema and see the tables, 
views and stored procedures defined in a database.    

� Database schema editingDatabase schema editingDatabase schema editingDatabase schema editing    ----    You can edit database schema using wizards. It is possible 
to create new tables and views and add columns to a table. 

� Data viewData viewData viewData view    ----    You can view the data stored in the tables. 
� SQL and DDL command executionSQL and DDL command executionSQL and DDL command executionSQL and DDL command execution    ----    You can write and execute SQL or DDL commands. 
� Migration of table definitionsMigration of table definitionsMigration of table definitionsMigration of table definitions    ----    You can migrate table definitions across databases from 

different vendors. 

 

For a list of supported drivers for NetBeans IDE 6.0, see: 
http://wiki.netbeans.org/DatabasesAndDrivershttp://wiki.netbeans.org/DatabasesAndDrivershttp://wiki.netbeans.org/DatabasesAndDrivershttp://wiki.netbeans.org/DatabasesAndDrivers    

5.15.15.15.1 MySQL SupportMySQL SupportMySQL SupportMySQL Support    

MySQL server is the most widely used relational database server. SXDE 1/08 includes 32–bit 

architecture of MySQL database. MySQL also has its own C client API, which is delivered with 
Web Stack. 
 

Supported Version – MySQL 5.0.45 

 
Assuming that you have already configured MySQL users and added necessary permissions, 
you can use NetBeans Database Explorer to add a new connection to the MySQL DB and 
manage tables as shown later in this document. 

5.1.15.1.15.1.15.1.1 Initial SetupInitial SetupInitial SetupInitial Setup    

For using MySQL with PHP you do not need to manually set up extension directories as it is 
already done in Web Stack but you still need to enable MySQL extension in the PHP.ini file. 

If you are using SXDE 1/08, you do not need to create mysql user or mysql group as mysql 

user and mysql group has been pre-configured. 

5.1.25.1.25.1.25.1.2 Starting the DBStarting the DBStarting the DBStarting the DB    

MySQL 5.0.45 for Solaris includes files necessary to register with SMF. The procedure to 
register MySQL service with SMF and starting the database server instance is described in the 
Web Stack Getting Started Guide. 
For starting the MySQL Server through the Web Stack menu, perform the following step: 
 

� Click All Applications > Developer Tools > Web Stack Admin > Start Apache2/MySQL 
Server. 

 
Optionally, you can also start MySQL server through command line: 
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� $ /usr/sbin/svcadm enable mysql:version_50 

 
You can also start MySQL server from the AMP GUI option tool. Click All Applications > 
Developer Tools > Web Stack Admin > Options. Go to General tab. Click Start Servers to start 
the MySQL Server along with Apache 2 web server. 
 

 
Use the AMP tool to start MySQL Server. 

 

MySQL 5.0 configuration file is located at /etc/mysql/5.0/my.cnf.  You can directly edit 

this file. The log file is located at /var/svc/log/application-database-

mysql:version_50.log. 

 
For creating a MySQL DB connection and testing the connection, refer to the next section on 
managing PostgreSQL connections. It is the same procedure except the part where you specify 
the MySQL DB driver that gets bundled with the NetBeans IDE. 
 

Note Note Note Note –––– The default user name is root and the corresponding password is an empty string. 

5.25.25.25.2 PostgreSQL SupportPostgreSQL SupportPostgreSQL SupportPostgreSQL Support    
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PostgreSQL is the open source enterprise database platform fully integrated into Solaris 10 
and Solaris Express Developer Edition (SXDE) with comprehensive support offerings from Sun. 
Unlike many proprietary databases, PostgreSQL is known as the 'failsafe DB' among the 
community. PostgreSQL is free of charge, and Sun includes a version of the database with 
every Solaris distribution. 
 

Supported VersionSupported VersionSupported VersionSupported Version – PostgreSQL 8.2 

5.2.15.2.15.2.15.2.1 Starting the DBStarting the DBStarting the DBStarting the DB    

In SXDE 1/08, before starting to use PostgreSQL DB, execute the following command as root 
user: 
 
/usr/sbin/svcadm enable postgresql:version_82 

You do not need to setup PostgreSQL data directory or create a postgres user as it is 

already created in Solaris OS. The above command will also start the PostgreSQL DB. 

5.2.25.2.25.2.25.2.2 Additional Additional Additional Additional ConfigurationConfigurationConfigurationConfiguration    

The pre-existing PostgreSQL SMF service is disabled by default. So, if you (as owner and single 
user of the machine) don't enable the SMF service, the default port won't be used. So you can 
start PostgreSQL on a non-default port also.  
If you want a PostgreSQL instance that is owned and managed by you and runs on the default 
port, just call initdb as shown in the above section followed by pg_ctl start.  
If you need to enable the pre-existing PostgreSQL SMF service, and if you want to manage it 
from another user name, then you need to assign the necessary privileges.  
Execute the following command just once: 
 

� $ usermod -P "Postgres Administration" <username> 

 

5.2.35.2.35.2.35.2.3 Adding Adding Adding Adding a a a a New ConnectionNew ConnectionNew ConnectionNew Connection    

For using PostgresSQL DB in your application through NetBeans, you need to let NetBeans 
know the existence and authentication information of the DB. For this reason, you need to 
create a new DB connection from NetBeans IDE. 
 

� Go to Service tab. 
� Right click Databases and select New Connection. 
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New DB Connection 

 

� In the New Database Connection dialog select PostgreSQL as the DB. 
� Enter the Driver name as org.postgresql.Driver if not present already. 

� Provide the Database URL. postgres is the name of the DB. 

� Enter user name and password (Default user name is postgres and password is an 
empty string ‘’). 

� Click OK. 

 

 
New Database Connection 

� Click Advanced tab and select public schema. 
� Click OK. 
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Select DB Schema 

5.2.45.2.45.2.45.2.4 Testing the ConnectionTesting the ConnectionTesting the ConnectionTesting the Connection    

For testing if the connection is successful, let us crate a DB from the DB Explorer as explained 
in the following section: 
 

� Right click on the newly added connection and select Create Table. 

 

 
Create Tables 

You can create a table using the easy-to-use GUI provided by NetBeans IDE. 
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� Add columns and their data types in the table. You can also set primary keys, define 
unique and null constraints from the tool. 

 

 
Create Tables 

When you have created the table, check if the table shows up in the Tables list in the DB 
Explorer. 
 

For more information on NetBeans DB support, see: 
http://db.netbeans.org/http://db.netbeans.org/http://db.netbeans.org/http://db.netbeans.org/    

5.35.35.35.3 Java DBJava DBJava DBJava DB Support Support Support Support    

Java DB is the Sun’s supported distribution of the open source Apache Derby database. Java DB 
is shipped with JDK 1.6 and NetBeans 6.0 that is available in Solaris OS. You can work with the 
bundled Java DB available through NetBeans IDE. There is no Solaris OS specific configuration 
so you can get started by reading the tutorial available at: 
http://wiki.netbeans.org/GetStartedwithJavaDB 

5.45.45.45.4 Entity Classes from DBEntity Classes from DBEntity Classes from DBEntity Classes from DB    

One of the main features of the Java Persistence API (JPA) that was introduced with the Java EE 
5 platform is that you can plug in any persistence provider that you want in your application. 
NetBeans together with its DB support and support to generate entity classes from an existing 
DB like MySQL DB or PostgreSQL DB makes building web applications easier. This section 
shows how you can use NetBeans’ wizards to access any running DB in Solaris and generate 
entity classes for updating the DB through your application. 
 
In the section on PostgreSQL, we created a GuestItinerary table through NetBeans. Now 
let us generate entity classes for that table using a wizard interface provided by NetBeans. 
 
Create a new web application that will connect to the PostgreSQL DB.  
 

� Click File > New Project. 
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� Select Web Application under Web Categories. 

 

 
Create New Project 

 

� Enter MyWebApp as the project name. 
� Select the server as Tomcat 6.0. See the section on adding Tomcat as a server in 

NetBeans. 
� Enter Context Path as /MyWebApp. This path is used for accessing the web 

application. 

 

 
Select target server as Tomcat 

Now a web application by name MyWebApp will be created by NetBeans. 
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� Right click on MyWebApp node and select New File 
� Select Entity Classes from Database under Persistence Category. 

 

 

Entity Classes from Database option. 

 

� In the Data Source drop down select New DataSource. 
� In the popup window, enter jdbc/postgres as the JNDI name and select the 

PostgreSQL DB connection from the list. 
� Click guestitinerary table from Available tables list. 

� Click Next. 
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Select the table for which entity classes should be generated 

Before you proceed, you need to create a persistence unit. We will use Toplink essentials. 
 

NoteNoteNoteNote - TopLink Essentials is the open-source community edition of Oracle’s TopLink 
object/relational mapping (ORM) tool. It provides the Java Persistence API (JPA) 
functionality—for creating, removing and querying across lightweight Java objects. 

 

� Click Create Persistence Unit. 
� Enter a name for persistence unit. 
� Select Persistence Provider as TopLink. 
� Select Data Source as jdbc/postgres. 

� Click create. 
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Create Persistence Unit 

 

TopLink Essentials as Persistence Provider 

 

At this stage, you cannot build your web application successfully as Tomcat does not come 
bundled with TopLink essentials like GlassFish Application Server. 
 

� Right click MyWebApp and click Properties. 
� Select Libraries in the Categories section. 
� In the right pane click Add Library and select TopLinkEssentials from the list. 
� Click OK. 
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Add Libraries 

Now MyWebApp is ready and you can start building your web application using the entity 
classes. 

5.55.55.55.5 Web Services from DBWeb Services from DBWeb Services from DBWeb Services from DB    

Another interesting aid provided by NetBeans is that you can create a web service that can 
perform CRUD operation on a selected table in a database. You can do these using SOA 
capabilities of NetBeans. From the plugins dialog, make sure that you have SOA plugin 
downloaded and installed or use the OpenESB NetBeans IDE bundle available for download at 
https://open-esb.dev.java.net/ 

 

� Right click your web application. 
� Select New File. 
� Under SOA category select WSDL from Database. 

 
Follow the steps in the wizard for selecting the table and the CRUD operations that you need 
to perform. When the WSDL file is generated you can use the WSDL (Web Service) as a BPEL 
partner link and start building your SOA applications.  
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A sample BPEL process updating a partner DB 

 
For instance, from your BPEL process you easily access a PostgreSQL or MySQL DB and can 
perform insert operations using a simple BPEL invoke activity. 
 

More InformationMore InformationMore InformationMore Information    
 - http://www.netbeans.org/kb/trails/soa.html 

6666 Getting HelpGetting HelpGetting HelpGetting Help    
Getting help is always easier for NetBeans IDE and Solaris OS. If you have a particular problem 
that you are facing with Web Stack, you can get help from the community mailing lists and 
official documentation at http://docs.sun.com. 

6.16.16.16.1 Mailing ListsMailing ListsMailing ListsMailing Lists    
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When you have a particular issue with NetBeans IDE, you can write to the NetBeans mailing 
list. To subscribe, unsubscribe, browse archives, or for more info on individual lists, please 
follow the appropriate links given in the NetBeans mailing list site. 
 

 - http://www.netbeans.org/community/lists/ 

 
Alternatively, if you have a question for the Web Stack community at OpenSolaris.org, check 
the following site for mailing list information. 
 

- http://opensolaris.org/os/project/webstack/Mailing_LIsts/ 

6.26.26.26.2 DocumentationDocumentationDocumentationDocumentation    

Web Stack documentation is available at docs.sun.com and OpenSolaris.org site. For 
information on starting with Solaris OS for web development, read Web Stack Getting Started 
Guide available at docs.sun.com. For any other issues pertaining to Web Stack documentation, 
send a mail to webstack-discuss@opensolaris.org. 
 

More Information 
  - NetBeans Documentation SiteNetBeans Documentation SiteNetBeans Documentation SiteNetBeans Documentation Site 
    http://www.netbeans.org/kb/60/ 
 - OpenSolaris Web Stack Project PageOpenSolaris Web Stack Project PageOpenSolaris Web Stack Project PageOpenSolaris Web Stack Project Page 
    http://opensolaris.org/os/project/webstack/ 
 - Cookbook for usinCookbook for usinCookbook for usinCookbook for using NetBeans on Solarisg NetBeans on Solarisg NetBeans on Solarisg NetBeans on Solaris 
   http://wiki.netbeans.org/NetBeansAndSolarisHowTos 


